How to end a webform early if a participant answers "N/A" to the first question?

We want to create a survey for people who have taken a certain course. The first question is, “How many years have you been a school nurse?” We have a few options (less than a year, a year, 3-5 years, etc.) and the last option is “N/A; not a school nurse.” We would like for the survey to end after this question for those who select “N/A,” because the rest of the questions only pertain to school nurses. Right now, I have it set so that the other questions can’t be accessed. However, a blank set of the questions is still shown in the response preview before submission.

If there’s a way to set it up where you can go right to the preview without viewing the list of blank questions, that would be ideal. I started getting error messages when the conditionals overlapped/overrode one another, so that’s why we are stumped as to the best way to go about it. Also, the conditionals don’t seem to have an option to “hide” other questions if the person gives a specific answer (the only options for conditionals I see are “shown,” “required,” or “set to”).

Any info/help/suggestions would be greatly appreciated. Thank you so much!

I’ve found that using fieldsets can sometimes help. You can say if the response “is not” N/A, then the other questions are shown, and when they are part of a fieldset, you can just indicate that the fieldset should be shown.

Also, do you need to have a preview page at all? If not, make sure it’s not enabled. You can choose which questions you want shown on the preview, but this would show for everyone, regardless of how they answer…

If you need people to see their submission but don’t have a preview page, you could have it emailed to them instead. In that case, in “Included email values” you can check “exclude empty components” and then I believe the questions that were not answered will not show.

Thank you so much for these suggestions! I think we are going to try to remove the preview page. It looks like the preview page is already disabled on our webform, so I’m not sure why it’s still showing up at the end of the survey…we will try to figure that out. Thank you again!