Troubleshooting SCORM - user can't complete Lectora course

I’ve published a SCORM course, authored in Lectora.

In EthosCE, the course object is required and has no passing grade.

When testing this as a user, my test user successfully completes the SCORM course, but cannot continue on to the next course object. The course object shows as incomplete and when I look in the course report it doesn’t show a completion date for the course object.

What am I doing wrong?

Hi @aives!

To troubleshoot SCORM, start by looking at the details of the attempt for the user who is stuck.

  1. Navigate to the course object report.
  2. Click on “Overview.” Completions and grades can be found on the Overview page.
  3. Click “View” to view more details regarding an individual’s progress or completion.
  4. Click on each launch to see more details.

You should see something like this:

Now look under registration information for the value of “Complete” and “Score.” What do you see there?

If the SCORM course object in EthosCE is set as required, the SCORM package must be published to have an LMS reporting status that either:

  1. Includes a grade: If the grade the learner earns in the launched SCORM package is higher than the passing grade set in the SCORM course object, the learner will be considered to have completed the SCORM course object.
  2. Reports the status of “Passed:” If the SCORM package reports the learner has “Passed” the learner will be considered to have completed the SCORM course object.

User Guide Reference on SCORM report

User Guide Reference on SCORM course objects

Here is what I see:

So you are saying that I need to update the course so that it reports the learner has passed? How do I do that?

This is old but seems relevant:

Love Lectora gems no.5: Setting SCORM functions

Yes, since you are not sending a score, you will need to update the SCORM package so that AICC_Lesson_Status returns a value of passed.

That worked! :grinning:

It is case sensitive so I entered: AICC_Lesson_Status = passed

Thank you!